Connecting to Fedora desktop from W10

I’ve enabled screen sharing with a password but no matter what VNC client I use, I get an error that pertains to a security setting mismatch. Only issue is I have no clue what that setting is. I read somewhere that you have to establish an SSH tunnel, which I have, but that doesn’t work either. Help me pls so I have a lab PC to follow along in this Linux Bible with :grin:

Is the VNC port open on Fedora? 5901 or whatever? Generally that’s the connection issue in my experience

Yeah 5900 by default. If I try 5901 I just get a connection refused error, so it’s getting through
Screenshot_2feh

I also read to try establishing an SSH connection with these parameters before initiating the VNC connection but I get a “Sorry, loopback connections are not enabled” error when I try the VNC

Screenshot_7

So your server is listening on 5900? Not 5901?

Are you entering IP:PORT when connecting?

Yes. In my case 10.10.10.123:5900. MobaXterm actually prompts me for the password and seems to authenticate before throwing an “Unsupported security type” error. This is a day old install of Fedora btw with no other modifications at all

Stop firewalld and see if you can get in.

sudo systemctl stop firewalld

Negative :confused: didn’t even know what the firewall service was called yet haha

Let me duplicate your steps to make sure I’m not missing anything.

VNC Server (Fedora) is listening on port 5900. This has been configured and there is a session ready with a vncuser and vncpasswd setup.

VNC Client (Windows) is trying to connect via IP address followed by port, example: 10.0.0.101:5900, and is receiving an error trying to connect.

Fedora and Windows are on the same network, and the firewall on Fedora has been stopped.

:thinking: Is that accurate?

Yes. Don’t know about the vnc user part. I just did this image

1 Like

Interesting! I did not know this feature was a thing. Peaking around, I think this may be of interest:

Did you install the package recommended above?

Following instructions from here

Assuming this is the same feature.


Sorry for my ignorance, I’m used to installing a VNC server and configuring it via config file.

1 Like

Nah I’m bone stock Fedora Desktop image. Just assumed that it worked. I’ll give that a try though

I’ve never used VNC lol

1 Like

Try running the command above and toggling the service off and on and see if that works.

Nope. Fack

1 Like

Try setting up a VNC server from scratch. It’s not so hard. I recommend your connection be on 5901 though :wink:

@SgtAwesomesauce Loves Fedora maybe he’s got experience with this.

And @Adubs

1 Like

Can you check netstat/ss for listening ports

1 Like

Ports open, Its a security issue.

So dont start now. Set up teamviewer with an account and be done with it.

VNC is generally a piece of shit and the only good experience I’ve had is with tightvnc server, which is windows only. Otherwise its laggy, resource heavy, and forces you to open up ports. Teamviewer is a better solution hands down.

If that wont suit your needs then I can dig around in fedora for you and tell you how to get vnc working.

2 Likes

Could also be an SELinux Issue that stops that

vi /etc/sysconfig/selinux

change line to

SELINUX=disabled

1 Like

no.

that requires a reboot to take effect.

just

setenforce 0

and try again

1 Like

but if it works, it needs to be set in the conf or it wont take effect after reboot.

1 Like