[solved] Weird upload speed behaviour

UPDATE: Solved!


OP:

@admindev @cekim @hidead @BirdoBaggins @other_network_gurus

help me out I don’t get it. My home servers get their upload cut to shit

Here’s the evidence (did multiple runs):

image

Here’s “topo”:

network-topo

What could be wrong?

Is QOS setup anywhere?

Check NIC error rates?

Change/reset “dumb switch”… sometimes their route tables get FUBAR… they are definitely not smart, but they are definitely not passive either.

Change ports/cables for fast/slow as well, but that should show in any errors on the interface.

pardon my ignorance, how do I check that?

all I know is ethtool coz I once had auto-neg off :man_shrugging:
image

image


power cycling the dumb switch didn’t do shit

fuck I should learn this networking business, I feel so dumb

image

local stuff is fine

Unless you have a long cable run - you should not see dropped packets in your house…

Are those 5 errors you moving wires around?

5 dropped might’ve been me running and failing to get connection for local test coz I didn’t disable firewall

+ serv <-> pc is all fine, it’s same wires lol

same problem at the router… its tables can be fucked.

let me just power cycle the fucker

let me just finish watching this vid lmao

image

power cycle didn’t help

Ok, if the localnet connection shows no difference, the router must be doing something different for the 2 clients… is one of them fixed ip and the other dynamic? Running local dns caching?

1 Like

the servers are static and are outside of dhcp pool

So the slow one is X and the fast one is Y?

Where X dhcp and Y is static? Or vice versa?

Are you running dns caching or proxy in your router? (i…e is your router the dns server for your clients?)
Do both clients have the same DNS entry in /etc/resolve.conf?

Also - and this one has bitten me so many times over the years - what does your nsswitch.conf say?

I cannot count the times I suddenly notice network slowness only to remember that I need to edit /etc/nsswitch.conf to change it to files dns myhostname (or whatever variation makes sense for your network).
That is
hosts: files dns myhostname
Or some variation of priorities depending on how you are setup.

lastly what does route -n say?

the fast one is my PC, it’s on dhcp
the 2 servers are static

all 3 of em are connected to gateway via dumb switch.

negative, tp link is too dumb for that, I wanted to tho :stuck_out_tongue:


image

I don’t have route, ip route -n says no such key…

/usr/sbin/route ?

QOS could be on your router…

you might have your gateway wrong somewhere…

negative, sir


yeah Arch and Deb 10 don’t have old ifconfig tools, only ip ones